XR650L w/Mikuni TM40. Impossible to ride

Introduce yourself, what you ride, post pics, seek or offer help, general chit-chat.
Post Reply
motosmanic
Posts: 4
Joined: Oct 24, 2018
Location: Norway
Rides: Honda XR650L 93'
Honda CBR1100XX 00'
Kawasaki ZXR750 J1 91'
Vehicles: BMW 523iAT 00'
BMW 528iA 00'

XR650L w/Mikuni TM40. Impossible to ride

Post by motosmanic » Wed Oct 24, 2018 9:10 am

Hi Guys,

I've just aquired myself and old XR650L. It has a rather unknown aftermaket exhaust named Krieger which is quite noisy. I've just started to check things on the bike as it runs ok on choke cold, but without it runs too lean. There is a pop in the exhaust once in a while and once this happens, the engine stops. Inside the carb which is a Mikuni TM40, i found a pilot Jet size 27.5 and a Main Jet size 132.5. I dont know the setting on the Main needle. I live at sea level and i was hoping anyone could suggest something i can do to make the bike usable. As it is now, its impossible to ride it cause of hesitation and lack of power especially when at operating temperature.

EDIT:
The Accel.pump setting seems out of tune as the rod is not activated until maybe 1/4 throttle. Check video below if you can.


motosmanic
Posts: 4
Joined: Oct 24, 2018
Location: Norway
Rides: Honda XR650L 93'
Honda CBR1100XX 00'
Kawasaki ZXR750 J1 91'
Vehicles: BMW 523iAT 00'
BMW 528iA 00'

Re: XR650L w/Mikuni TM40. Impossible to ride

Post by motosmanic » Wed Oct 24, 2018 11:20 am

I have a spesific question to those of you who have the Mikuni TM40 carburetor. Can you check for me the approx gap you have between the accel.pump rod and the lever which operates it when bike is at idle?

JoeRC51
Posts: 65
Joined: Jun 10, 2016

Re: XR650L w/Mikuni TM40. Impossible to ride

Post by JoeRC51 » Wed Oct 24, 2018 5:08 pm

I don't know the gap , but mine starts the squirt only slightly after the slide moves. I've got 17.5 pilot and 160 main jets , clip in the middle.

motosmanic
Posts: 4
Joined: Oct 24, 2018
Location: Norway
Rides: Honda XR650L 93'
Honda CBR1100XX 00'
Kawasaki ZXR750 J1 91'
Vehicles: BMW 523iAT 00'
BMW 528iA 00'

Re: XR650L w/Mikuni TM40. Impossible to ride

Post by motosmanic » Thu Oct 25, 2018 12:31 am

JoeRC51 wrote:I don't know the gap , but mine starts the squirt only slightly after the slide moves. I've got 17.5 pilot and 160 main jets , clip in the middle.
Thanks ;) At least now i know that mine was far off on the setting. I guess a baseline of 1mm isn't too bad for me. Regarding my Pilot Jet which is 27.5, It should be large enough to be able to get a rich enough idle. But i do get the pop's in exhaust once in a while and engine stops, which probably is due to a lean condition. Im hoping fixing the pumpgap, will also fix the direct hanging idle i get when blipping the throttle. That since with the pump now squirting to rich out the mix. Also i hope to make mid range RPM work ok even with the small 132.5 Main Jet even if maybe too small for full throttle. Anyone have thoughts on this?

Post Reply

SPONSOR